Opened 14 years ago

Closed 12 years ago

#125 closed Defect (Works for Me)

send message with action tense is broken

Reported by: brennan@… Owned by: timothy
Component: Colloquy (Mac) Version: 2.0 (Mac)
Severity: Major Keywords: scripted actions
Cc:

Description

Steps to repro:

tell application "Colloquy" to send message "/nick testNick" with action tense

Expected result: nick gets changed

Actual result: "/nick testNick" is sent as chat text

This means it's impossible to run actions from applescript.

Change History (4)

comment:1 Changed 14 years ago by timothy

  • Resolution set to wontfix
  • Status changed from new to closed

This is not an action. That is a command. to send commands with AS you need to use "send raw command".

An example would be:

send raw command "NICK testNick" to first connection

You can also do this for nick changes:

set nickname of first connection to "testNick"

comment:2 Changed 13 years ago by brennan@…

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Ah, come on timothy. First of all, IRC users don't generally know raw event syntax, so it would be reasonable to expect something like /nick to be handled decently.

And it doesn't alter the fact that the following example fails

tell application "Colloquy"

tell first connection

tell chat room 1

send message "/me waves" with action tense

end tell

end tell

end tell

... and that's very definately an action, not a command.

BTW if you leave out the slash, colloquy crashes!

comment:3 Changed 13 years ago by timothy

That does not crash for me. "send message" is intended only for direct chat messages. We could consider looking for a / and parsing it as a command. However, a script might want to send a message that starts with a / (maybe a file path), how would we allow that? I would prefer to have a "send command" call.

comment:4 Changed 12 years ago by timothy

  • Resolution set to worksforme
  • Status changed from reopened to closed

Put simply, "with action tense" does not mean "run a /command". It means "send this text as an action", like "* xenon runs".

This is: send message "runs" with action tense

What you want is better described in #338. Closing this because action tense works as designed. Will keep #338 to track the rest of this.

Note: See TracTickets for help on using tickets.