Opened 12 years ago

Closed 5 years ago

#1230 closed Defect (Fixed)

Server password might not be stored

Reported by: kkaefer Owned by: timothy
Component: Colloquy (Mac) Version: 2.1 (Mac)
Severity: Normal Keywords:
Cc: akempgen

Description

When connecting to a bouncer or proxy, a server password is usually required to connect to the server in the first place (not auth against nickserv). For some reason, the info box for the connection doesn't display that password after it has been closed an reopened. It looks like Colloquy doesn't save that password (I can't find it in the Keychain either).

When creating a new connection and entering the password there, authentication works for the *first* connect, but not for subsequent connects.

#1055 might be related to this.

Change History (14)

comment:1 Changed 12 years ago by kkaefer

This is still an issue. Is there any way how I can help to resolve this problem?

comment:2 Changed 7 years ago by jamver

This still happens in Colloquy 2.4.

Is anybody looking at this?

comment:3 Changed 7 years ago by aperezbios

This is still happening for me in Colloquy 2.4.1, in the context of NickServ? passwords.

comment:4 Changed 7 years ago by ptarjan

Still happening in Version 2.4.1 (5738)

comment:5 Changed 6 years ago by anonymous

Happening to me too.

comment:6 Changed 6 years ago by kurt@…

Still in 2.4.2

comment:7 Changed 6 years ago by anonymous

Broken in 2.4.2. It looks like Colloquy isn't saving the username into the Keychain item. Workaround: set the "Account" field field of the Keychain item to the server username.

comment:8 Changed 6 years ago by anonymous

Worked for me: Enter the password, close the settings box, exit completely out of Colloquy. Reopen and server password should be saved. This may not work for NickServ? passwords.

comment:9 Changed 6 years ago by colindean

I can confirm that both anonymous workarounds worked for me.

comment:10 Changed 6 years ago by anonymous

If I created a new connection with username and password, it would connect fine. If I then disconnect and reconnect, it seems to forget the password. But if I quit Colloquy and start it again, it remembers the password. This bug bugs me! But at least now I know this small workaround.

comment:11 Changed 5 years ago by sTh0r

this workaround works only for 1 connection, if I try to have multipel connections to the same bouncer (for multipel networks), the first "keychain object" is overwriten with the new one...

comment:12 Changed 5 years ago by carpii.uk@…

Have had this problem for ages, including latest Version 2.4.3 (6011) on OSX 10.9.4

I'm not doing anything special such as bouncing etc, and I only have one IRC server connection open.

Everytime I connect to irc.freenode.net I am prompted for a nickserv password.
I also tell Colloquy to save it for next time, but this doesn't help.

Inspecting my keychain, the nickserv password is there, but Colloquy just refuses to use it.

My OSX Keychain fields:

    Name: irc.freenode.net
    Kind: Internet Password
    Account: <my IRC nickname> (same one NickServ prompts for, and same one I'm connected to freenode with)
    Where: irc://irc.freenode.net
    Password: My correct NickServ pass

I wonder if this is even the same issue as OP originally posted, but any attempt to report this particular bug just gets marked as a duplicate and refers to this ticket.

I'd love for this to be fixed, its really frustrating

comment:13 Changed 5 years ago by anonymous

this software just sucks and no support. Find a new app!

comment:14 Changed 5 years ago by zach

  • Resolution set to Fixed
  • Status changed from new to closed

r6321 updated how we handle passwords and should fix this.

Note: See TracTickets for help on using tickets.