Opened 10 years ago

Last modified 7 years ago

#1229 reopened Enhancement

Using a proxy from GUI

Reported by: Rarok Owned by: timothy
Component: Colloquy (Mac) Version: 2.1 (Mac)
Severity: Normal Keywords: proxy, GUI, badpatch
Cc: rob@…, grahamperrin, drewish@…, az@…

Description

Hi, I think It shouldn't be hard. I only want to make a suggestion:
Including the proxy selection from the GUI.
In the website I found how to use a proxy and/or ssh tunneling but they require to use the shell and some users don't know how to use it. I think that giving the option to consigure the proxy from the GUI should be very good for novice users.

Sorry for my bad english

Change History (12)

comment:1 follow-up: Changed 10 years ago by robclark

  • Cc rob@… added

the attached patch makes proxy support work... no additional GUI, it uses proxy settings configured in system preferences

comment:2 Changed 9 years ago by encro

This would be great if Rarok's patch could be landed on trunk.

comment:3 Changed 9 years ago by timothy

  • Status changed from new to assigned

I'll take a look at landing this.

comment:4 in reply to: ↑ 1 Changed 9 years ago by xApple

This looks interesting.. how does one install such a patch ?

Colloquy really needs to follow the system wide proxy settings found in the system preferences...

comment:5 Changed 9 years ago by grahamperrin

  • Cc grahamperrin added

/me watches this ticket:1229 and related ticket:747.

comment:6 Changed 9 years ago by Rinoa

  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #747. The patch needs cleaned up in order for it to be landed.

comment:7 Changed 9 years ago by zach

  • Resolution duplicate deleted
  • Status changed from closed to reopened

This ticket allows for more kinds of proxies then just http, even if the patch is only for http proxies and should still be kept open.

comment:8 Changed 9 years ago by akempgen

  • Keywords GUI, patch added; GUI removed

comment:9 Changed 9 years ago by zach

  • Keywords badpatch added; patch removed

The patch shouldn't be modifying AsyncSocket?... There's better ways to provide proxy support.

comment:10 Changed 9 years ago by psa

How should this be done? If I was implementing from scratch I'd use CFNetwork...

comment:11 Changed 8 years ago by drewish

  • Cc drewish@… added

comment:12 Changed 7 years ago by witsch

  • Cc az@… added
Note: See TracTickets for help on using tickets.