Opened 11 years ago

Closed 10 years ago

#1190 closed Defect (Works for Me)

Colloquy goes into a state where one can't type anything

Reported by: shreevatsa Owned by: timothy
Component: Colloquy (Mac) Version:
Severity: Blocker Keywords:
Cc:

Description

I often get into a situation where I can't type anything in Colloquy windows. I am not sure how exactly to reproduce it, but here is something that seems to mostly work:

  • Type something (in some channel, not in the server console or other windows)
  • Hit Cmd-A (for Select All)
  • Hit Option-Delete (Backspace) [maybe Cmd-Delete also works here?]
  • Hit Cmd-Z (for Undo)

Now, if everything goes (not) well, you can't type anything at all in any of the chat windows or the server console. You *can* paste from other windows. You *cannot* hit Return to send the pasted message. You *can* hit Cmd-J (for example) and type channel names in the window that pops up. You just can't type in any chat windows.

Minimising and restoring Colloquy does not help; the only way out is to restart Colloquy.

Change History (4)

comment:1 Changed 11 years ago by shreevatsa

Today I deleted something and hit Cmd-Z, and Colloquy crashed.

comment:2 in reply to: ↑ description Changed 11 years ago by shreevatsa

  • The Cmd-A seems unnecessary, even deleting something simply with Option-Delete (and then hitting Cmd-Z) seems to screw it up sometimes.
  • Option-Delete seems unnecessary too; deleting something with just Delete (and then hitting Cmd-Z) seems to screw it up too.

Can I turn on debugging or something to see what's happening? It is not perfectly reproducible but happens fairly frequently.

comment:3 in reply to: ↑ description Changed 11 years ago by shreevatsa

I can also reproduce this by using Ctrl-K and then Cmd-Z.

Basically, clearing text (in whatever way) and doing Undo causes this annoying bug. I wish I could help debug it, but I don't know how to...

comment:4 Changed 10 years ago by jane

  • Resolution set to worksforme
  • Status changed from new to closed

please reopen if you continue to have problems (including more details about which colloquy version you're using, your OS, etc.). can't reproduce in latest colloquy on 10.5.5.

Note: See TracTickets for help on using tickets.