Opened 10 years ago

Closed 9 years ago

#1166 closed Defect (Works for Me)

Clearing scrollback sometimes causes Colloquy to freeze

Reported by: jayare Owned by: timothy
Component: Colloquy (Mac) Version: 2.1 (Mac)
Severity: Critical Keywords:


Clearing the scrollback, either by pressing the "Clear" button on the toolbar or by typing /clear, occasionally causes Colloquy to freeze. No beach ball -- it just becomes unresponsive. When this happens, the app must be quit via the Dock.

Change History (4)

comment:1 Changed 10 years ago by SineOtter

I've run into this issue occasionally since 10.3.9 and whatever builds were current then, and I think it has something to do with the WebKit? view or something.

Easy work around is just to hit the minimize button on the Colloquy window to minimize to the dock. When you bring it back up, it'll be working fine. No need to quit.

comment:2 Changed 10 years ago by jayare

Thanks for the hint! I'll try that the next time it happens.

comment:3 Changed 10 years ago by jayare

That didn't work for me, unfortunately. When it came back up from being minimized, scrollback had been cleared, but I couldn't type anything in or see activity in the channel.

comment:4 Changed 9 years ago by timothy

  • Resolution set to worksforme
  • Status changed from new to closed

Can't reproduce. Reopen if this still happens on Tiger or Leopard.

Note: See TracTickets for help on using tickets.