Opened 12 years ago

Closed 9 years ago

#1113 closed Defect (Fixed)

XMPP does not allow username with @ in it

Reported by: velma Owned by: Rinoa
Component: Colloquy (Mac) Version: 2.1 (Mac)
Severity: Major Keywords: jabber xmpp
Cc:

Description

When trying to join an XMPP server using a username such as user@… it complains that "The username you specified is invalid because it contains spaces or other non-alphanumeric characters." Although many XMPP servers are set up with virtual hosting where entering the domain is neccessary for the username.

Change History (5)

comment:1 Changed 12 years ago by Rinoa

  • Owner changed from timothy to Rinoa
  • Status changed from new to assigned

comment:2 Changed 12 years ago by Rinoa

Fixed in [3753]

comment:3 Changed 12 years ago by Rinoa

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:4 Changed 9 years ago by joestump

  • Resolution fixed deleted
  • Status changed from closed to reopened

Was there a regression on this? http://skitch.com/joestump/n77r5/colloquy Currently, I don't think Colloquy is usable with XMPP over SSL.

comment:5 Changed 9 years ago by zach

  • Resolution set to fixed
  • Status changed from reopened to closed

The problem was '.', not '@'. Fixed in [5077]

Note: See TracTickets for help on using tickets.