Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1095 closed Defect (Fixed)

3720 breaks on 10.3

Reported by: Luke Owned by: timothy
Component: Colloquy (Mac) Version: 2.1 (Mac)
Severity: Blocker Keywords: crash
Cc:

Description (last modified by Rinoa)

Running Colloquy without problems until the 2.1 (3720) release, upon which Colloquy, upon starting the program, crashes automatically with the following error report every time:

dyld: /Downloaded Files/Colloquy?.app/Contents/MacOS/Colloquy Undefined symbols:
/Downloaded Files/Colloquy?.app/Contents/MacOS/Colloquy undefined reference to .objc_class_name_NSAffineTransform expected to be defined in Foundation

Change History (8)

comment:1 Changed 12 years ago by Rinoa

  • Description modified (diff)
  • Summary changed from Colloquy Vers 2.1 auto-crash on program launch. to 3720 breaks on 10.3

The new release has busted 10.3 versions.

Please submit crash logs on relaunch of the application. They get sent to our server where we can look at all crashes and see which ones relate, are the same, and the seriousness of each crash.

comment:2 Changed 12 years ago by dglazkov

If this helps any, running 3590 on 10.3.9 and have the same issue. However, I am able to occasionally avoid crashes by disabling auto-connect and connecting manually after the app starts.

comment:3 Changed 12 years ago by net20

This page claims NSAffineTransform is defined in the Application Kit, not the Foundation, on 10.3. Is this at all relevant?

comment:4 follow-up: Changed 12 years ago by alphabud

Please provide download in download folder of the last version that DID work on 10.3.9
The most recent version to download there is v2D14! This is ancient... and i would rather I did not have to go find a new client.

comment:5 in reply to: ↑ 4 ; follow-up: Changed 12 years ago by Rinoa

Replying to alphabud:

Please provide download in download folder of the last version that DID work on 10.3.9
The most recent version to download there is v2D14! This is ancient... and i would rather I did not have to go find a new client.

http://colloquy.info/downloads/

Go to the nightlies folder. It's in there. Just look for the most recent date, which would be 2.26.07.

comment:6 in reply to: ↑ 5 Changed 12 years ago by falsedan

http://colloquy.info/downloads/nightlies/2.26.07.zip

As someone who has only very recently heard of Colloquy, I am confused by the lack of information the website has about this bug. It would be nice if the Downloads page was changed to explicitly say "Requires 10.4 or higher, 10.3.9 users please use use the previous release" instead of "Requires 10.3.9 or higher" until this ticket is resolved.

comment:7 Changed 12 years ago by timothy

  • Resolution set to fixed
  • Status changed from new to closed

I think I fixed this in [3755].

comment:8 Changed 12 years ago by falsedan

yeah launches for me now, thanks timothy

Note: See TracTickets for help on using tickets.