Opened 12 years ago

Closed 9 years ago

#1063 closed Defect (Fixed)

New Leopard Behavior Causes Console Error Message (no Crash)

Reported by: brent Owned by: timothy
Component: Colloquy (Mac) Version: 2.3 (Mac)
Severity: Trivial Keywords: Leopard
Cc:

Description

Running Colloquy Version 2.1 (3590) under Leopard (10.5 -- 9A466), a warning is generated in the console:

6/27/07 9:01:57 PM Colloquy[13497] -[NSConcreteAttributedString initWithString:] called with nil string argument. This has undefined behavior and will raise an exception in post-Leopard linked apps. This warning is displayed only once.

At the moment, this causes no program errors.

Change History (8)

comment:1 Changed 11 years ago by grahamperrin

@ brent

Please, is this still an issue for you?

comment:2 Changed 11 years ago by grahamperrin

  • Severity changed from blocker to normal

comment:3 Changed 11 years ago by Robby

  • priority changed from Highest to Normal
  • Resolution set to worksforme
  • Status changed from new to closed

No response.

comment:4 Changed 11 years ago by zach

  • Resolution worksforme deleted
  • Status changed from closed to reopened

This still happens on Leopard.

comment:5 Changed 11 years ago by mikehale

  • Severity changed from Normal to Blocker
  • Version changed from 2.1 (Mac) to 2.2 (Mac)

I'm seeing this on my machine with: Version 2.2.1 (4132). It keeps me from being able to connect to any irc servers.

comment:6 Changed 11 years ago by mikehale

I was able to fix this issue by using AppZapper? to delete the application, plist, and library support files, and then reinstalling Colloquy.

comment:7 Changed 11 years ago by zach

  • priority changed from Normal to Lowest
  • Severity changed from Blocker to Trivial

comment:8 Changed 9 years ago by akempgen

  • milestone set to Colloquy 2.4
  • Resolution set to fixed
  • Status changed from reopened to closed
  • Version changed from 2.2 (Mac) to 2.3 (Mac)

Fixed in r4844

Note: See TracTickets for help on using tickets.